Installing Graphite - Error - The SECRET_KEY setting must not be empty

ImproperlyConfigured(“The SECRET_KEY setting must not be empty.”)

This a case of the wrong version of django. Graphite is looking for 1.4. So, use pip to get the right version:

pip install Django==1.4

On Ubuntu 12.10, this got the correct version for me. If not, you may have to use wget to get the correct version from djangoproject.com.

References
https://answers.launchpad.net/graphite/+question/224789